<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
	<title>Nakfa’s Symbolic Value | Awate</title>
	<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<meta name="og:title" content="Nakfa’s Symbolic Value" />
<meta name="og:image" content="http://awate.com/wp-content/uploads/2017/03/dawit-mesfin-2017.jpg" />
<meta name="og:type" content="article" />
<meta name="og:description" content="It is embarrassing to witness, in this day and age, abnormal developments creep into our campaigns for human and democratic rights of Eritreans. The aim of the sectarian and ethnocentric maneuver is t" />
<meta name="og:url" content="http://awate.com/nakfas-symbolic-value/" />
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="shortcut icon" href="favicon.ico" >
	<link rel="icon" href="animated_favicon.gif" type="image/gif" >
	<link href="//netdna.bootstrapcdn.com/font-awesome/4.0.3/css/font-awesome.css" rel="stylesheet">
	<link href='http://fonts.googleapis.com/css?family=Roboto' rel='stylesheet' type='text/css'>
	<link href='http://fonts.googleapis.com/css?family=Raleway' rel='stylesheet' type='text/css'>
	<link href='http://fonts.googleapis.com/css?family=Ubuntu' rel='stylesheet' type='text/css'>
	
	<link rel="pingback" href="http://awate.com/xmlrpc.php" />
		<!--[if IE 9]>
	<link rel="stylesheet" href="http://awate.com/wp-content/themes/News/css/ie9.css" />
	<![endif]-->
	<!--[if lt IE 9]>
	<link rel="stylesheet" href="http://awate.com/wp-content/themes/News/css/ie8.css" />
	<![endif]-->
	
		
	<!--[if lt IE 9]>
<script src="http://awate.com/wp-content/themes/News/js/html5shiv.js"></script>
<script src="http://awate.com/wp-content/themes/News/js/respond.js"></script>
<![endif]-->
	
			  
	
<style type="text/css">
	.gk-page { max-width: 1230px; }
		#gk-mainbody-columns > aside { width: 27%;}
	#gk-mainbody-columns > section { width: 73%; }
	#gk-mainbody-columns { background-position: 73% 0!important; }
		
		#gk-content-wrap { width: 100%; }
		
		#gk-mainbody > div { width: 100%; }
		
</style>

	
		
			
	
		<script type="text/javascript">
		var thickboxL10n = {
			"next":"Next >",
			"prev":"< Prev",
			"image":"Image",
			"of":"of",
			"close":"Close",
			"noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.",
			"loadingAnimation":"http://awate.com/wp-includes/js/thickbox/loadingAnimation.gif",
			"closeImage":"http://awate.com/wp-includes/js/thickbox/tb-close.png"
		};
	</script>

		<script type="text/javascript">var baseurl = "http://awate.com";var adminurl = "http://awate.com/wp-admin/";</script><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Awate.com &raquo; Feed" href="http://awate.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Awate.com &raquo; Comments Feed" href="http://awate.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Awate.com &raquo; Nakfa’s Symbolic Value Comments Feed" href="http://awate.com/nakfas-symbolic-value/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/awate.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6.4"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ewd-progress-bar-css'  href='http://awate.com/wp-content/plugins/easy-wordpress-donations/includes/css/progress-bar.css.php?ver=1.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='ewd-front-end-css'  href='http://awate.com/wp-content/plugins/easy-wordpress-donations/includes/css/front-end.css?ver=1.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-normalize-css'  href='http://awate.com/wp-content/themes/News/css/normalize.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-template-css'  href='http://awate.com/wp-content/themes/News/css/template.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-wp-css'  href='http://awate.com/wp-content/themes/News/css/wp.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-stuff-css'  href='http://awate.com/wp-content/themes/News/css/stuff.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-wpextensions-css'  href='http://awate.com/wp-content/themes/News/css/wp.extensions.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-extensions-css'  href='http://awate.com/wp-content/themes/News/css/extensions.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-typography-css'  href='http://awate.com/wp-content/themes/News/css/shortcodes.typography.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-elements-css'  href='http://awate.com/wp-content/themes/News/css/shortcodes.elements.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-template-css'  href='http://awate.com/wp-content/themes/News/css/shortcodes.template.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-desktop-small-css'  href='http://awate.com/wp-content/themes/News/css/desktop.small.css?ver=4.6.4' type='text/css' media='(max-width: 1230px)' />
<link rel='stylesheet' id='gavern-tablet-css'  href='http://awate.com/wp-content/themes/News/css/tablet.css?ver=4.6.4' type='text/css' media='(max-width: 1030px)' />
<link rel='stylesheet' id='gavern-tablet-small-css'  href='http://awate.com/wp-content/themes/News/css/tablet.small.css?ver=4.6.4' type='text/css' media='(max-width: 820px)' />
<link rel='stylesheet' id='gavern-mobile-css'  href='http://awate.com/wp-content/themes/News/css/mobile.css?ver=4.6.4' type='text/css' media='(max-width: 580px)' />
<link rel='stylesheet' id='gavern-style-css'  href='http://awate.com/wp-content/themes/News/css/style2.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-override-css'  href='http://awate.com/wp-content/themes/News/css/override.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-thickbox-css'  href='http://awate.com/wp-includes/js/thickbox/thickbox.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='videogallery_css-css'  href='http://awate.com/wp-content/plugins/contus-video-gallery/css/style.min.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='wprmenu.css-css'  href='http://awate.com/wp-content/plugins/wp-responsive-menu/css/wprmenu.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='wprmenu-font-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C300%2C600&#038;ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='wpsr-socialbuttons-css'  href='http://awate.com/wp-content/plugins/wp-socializer/public/css/wp-socializer-buttons-css.css?ver=2.4.9.9' type='text/css' media='all' />
<script type='text/javascript' src='http://awate.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://awate.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://awate.com/wp-content/plugins/custom-post-donations/scripts/jquery.cpDonations.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://awate.com/wp-content/plugins/contus-video-gallery/js/script.min.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://awate.com/wp-content/plugins/wp-responsive-menu/js/jquery.transit.min.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://awate.com/wp-content/plugins/wp-responsive-menu/js/jquery.sidr.js?ver=4.6.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wprmenu = {"zooming":"no","from_width":"768","swipe":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='http://awate.com/wp-content/plugins/wp-responsive-menu/js/wprmenu.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://awate.com/wp-content/plugins/wp-socializer/public/js/wp-socializer-floating-bar-js.js?ver=2.4.9.9'></script>
<script type='text/javascript' src='http://awate.com/wp-content/themes/News/js/widgets/slideshow.js?ver=4.6.4'></script>
<link rel='https://api.w.org/' href='http://awate.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://awate.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://awate.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Adulisian Narratives: Standing Athwart The Abyssinian Paradigm' href='http://awate.com/adulisian-narratives-standing-athwart-the-abyssinian-paradigm/' />
<link rel="canonical" href="http://awate.com/nakfas-symbolic-value/" />
<link rel='shortlink' href='http://awate.com/?p=165824' />
<link rel="alternate" type="application/json+oembed" href="http://awate.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fawate.com%2Fnakfas-symbolic-value%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://awate.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fawate.com%2Fnakfas-symbolic-value%2F&#038;format=xml" />
		<style id="wprmenu_css" type="text/css" >
			/* apply appearance settings */
			#wprmenu_bar {
				background: #0099cc;
			}
			#wprmenu_bar .menu_title, #wprmenu_bar .wprmenu_icon_menu {
				color: #ffffff;
			}
			#wprmenu_menu {
				background: #0099cc!important;
			}
			#wprmenu_menu.wprmenu_levels ul li {
				border-bottom:1px solid #ffffff;
				border-top:1px solid #ffffff;
			}
			#wprmenu_menu ul li a {
				color: #ffffff;
			}
			#wprmenu_menu ul li a:hover {
				color: #e25402;
			}
			#wprmenu_menu.wprmenu_levels a.wprmenu_parent_item {
				border-left:1px solid #ffffff;
			}
			#wprmenu_menu .wprmenu_icon_par {
				color: #ffffff;
			}
			#wprmenu_menu .wprmenu_icon_par:hover {
				color: #e25402;
			}
			#wprmenu_menu.wprmenu_levels ul li ul {
				border-top:1px solid #ffffff;
			}
			#wprmenu_bar .wprmenu_icon span {
				background: ;
			}
							#wprmenu_menu, #wprmenu_menu ul, #wprmenu_menu li {
					border-bottom:none!important;
				}
				#wprmenu_menu.wprmenu_levels > ul {
					border-bottom:1px solid #ffffff!important;
				}
				.wprmenu_no_border_bottom {
					border-bottom:none!important;
				}
				#wprmenu_menu.wprmenu_levels ul li ul {
					border-top:none!important;
				}
			
			#wprmenu_menu.left {
				width:80%;
				left: -80%;
			    right: auto;
			}
			#wprmenu_menu.right {
				width:80%;
			    right: -80%;
			    left: auto;
			}


			
						/* show the bar and hide othere navigation elements */
			@media only screen and (max-width: 768px) {
				html { padding-top: 42px!important; }
				#wprmenu_bar { display: block!important; }
				div#wpadminbar { position: fixed; }
				Array { display:none!important; }			}
		</style>
		<link href="http://awate.com/?opensearch_description=1" title="Awate.com" rel="search" type="application/opensearchdescription+xml" />	
	<style type="text/css">
</style>
	<script type="text/javascript">
           $GK_PAGE_URL = 'http://awate.com';
           $GK_TMPL_URL = 'http://awate.com/wp-content/themes/News';
           $GK_TMPL_NAME = 'news';
           $GK_MENU = [];
           $GK_MENU["mainmenu"] = [];
           $GK_MENU["mainmenu"]["animation"] = "none";
           $GK_MENU["mainmenu"]["animation_speed"] = "fast";
           $GK_MENU["topmenu"] = [];
           $GK_MENU["topmenu"]["animation"] = "none";
           $GK_MENU["topmenu"]["animation_speed"] = "normal";
           $GK_MENU["footermenu"] = [];
           $GK_MENU["footermenu"]["animation"] = "none";
           $GK_MENU["footermenu"]["animation_speed"] = "normal";
        </script>
		
		
		
	</head>
<body class="single single-post postid-165824 single-format-standard" data-tablet-width="1030">


<section id="gk-content-top" class="gk-page">
                                                <h1>
                                <a href="http://awate.com" class="cssLogo">Awate <small>Fearless News, Opinion, Analysis On Eritrea And Beyond</small></a>
                        
			</h1>
                     	<div id="gk-slogan">
				<img src="http://awate.com/inform_inspire_embolden.png" alt="Inform, Inspire, Embolden. Reconcile!"> </img> 
			</div>
                        		
		<div id="gk-search">
					<div class="textwidget"><style>
.responsive-ad-unit-for-the-header { width: 320px; height: 50px; }
@media(min-width: 800px) { .responsive-ad-unit-for-the-header { width: 728px; height: 90px; } }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive Ad Unit for the Header -->
<ins class="adsbygoogle responsive-ad-unit-for-the-header"
     style="display:inline-block"
     data-ad-client="ca-pub-7042793297334268"
     data-ad-slot="4157653075"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
			</div>
		
	<!--[if IE 8]>
	<div class="ie8clear"></div>
	<![endif]-->
</section>
<section id="gk-page-top" class="gk-page">
		<div class="gk-page">
							<ul id="main-menu" class="menu gk_normal"><li id="menu-item-4064" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-4064"><a href="http://awate.com">Home</a></li>
<li id="menu-item-55114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-55114"><a href="http://awate.com/category/awate-team/">Awate Team</a>
<div class="sub-menu"><ul>
	<li id="menu-item-55106" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55106"><a href="http://awate.com/category/pencil/">Pencil</a></li>
</ul></div>
</li>
<li id="menu-item-55096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55096"><a href="http://awate.com/category/gedab-news/">Gedab News</a></li>
<li id="menu-item-55167" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-55167"><a href="http://awate.com/category/articles/">Articles</a></li>
<li id="menu-item-55098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-55098"><a href="http://awate.com/category/columns/">Columns</a>
<div class="sub-menu"><ul>
	<li id="menu-item-55107" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55107"><a href="http://awate.com/category/perspective/">Perspective</a></li>
	<li id="menu-item-55111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55111"><a href="http://awate.com/category/tebeges/">Tebeges</a></li>
	<li id="menu-item-65966" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65966"><a href="http://awate.com/category/alnahda/">Al-Nahda</a></li>
	<li id="menu-item-55105" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55105"><a href="http://awate.com/category/negarit/">Negarit</a></li>
	<li id="menu-item-55108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55108"><a href="http://awate.com/category/pointblank/">Pointblank</a></li>
	<li id="menu-item-55097" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55097"><a href="http://awate.com/category/almaseer/">AlMaseer</a></li>
	<li id="menu-item-55112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55112"><a href="http://awate.com/category/u-turn/">U-Turn</a></li>
	<li id="menu-item-55101" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55101"><a href="http://awate.com/category/flipside/">Flipside</a></li>
	<li id="menu-item-55099" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55099"><a href="http://awate.com/category/belly-of-the-beast/">Belly Of The Beast</a></li>
	<li id="menu-item-55100" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55100"><a href="http://awate.com/category/branna/">Branna</a></li>
	<li id="menu-item-55102" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55102"><a href="http://awate.com/category/harmony/">Harmony</a></li>
	<li id="menu-item-55103" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55103"><a href="http://awate.com/category/insight/">Insight</a></li>
	<li id="menu-item-55104" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55104"><a href="http://awate.com/category/kind-citizen/">Kind Citizen</a></li>
	<li id="menu-item-55109" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55109"><a href="http://awate.com/category/reflections/">Reflections</a></li>
	<li id="menu-item-55110" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55110"><a href="http://awate.com/category/spotlight/">Spotlight</a></li>
	<li id="menu-item-55113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55113"><a href="http://awate.com/category/verbatim/">Verbatim</a></li>
</ul></div>
</li>
<li id="menu-item-55094" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55094"><a href="http://awate.com/category/%d8%b9%d8%b1%d8%a8%d9%8a/">عربي</a></li>
<li id="menu-item-55095" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55095"><a href="http://awate.com/category/%e1%89%b5%e1%8c%8d%e1%88%ad%e1%8a%9b/">ትግርኛ</a></li>
</ul>						
						<div id="gk-user-area">
								<a href="wp-login.php?action=login" id="gk-login">Login</a>
								
							</div>
					</div>
	</section>
<div class="gk-page-wrap gk-page">
	<div id="gk-mainbody-columns">			
		<section>
			<div id="gk-content-wrap">
								
								
				<!-- Mainbody, breadcrumbs -->
								<div id="gk-breadcrumb-area">
					<nav class="gk-breadcrumbs"><a href="http://awate.com" class="gk-home">Awate.com</a><a href="http://awate.com/category/articles/" rel="category tag">Articles</a><span class="gk-current">Nakfa’s Symbolic Value</span></nav>					<!--[if IE 8]>
					<div class="ie8clear"></div>
					<![endif]-->
				</div>
								
							

<section id="gk-mainbody">
	<div>
					
	<article id="post-165824" class="post-165824 post type-post status-publish format-standard has-post-thumbnail hentry category-articles">
		<header>
			
<h1>
			Nakfa’s Symbolic Value		
	</h1>

						 		
		<ul class="meta">
				
				<li>
			<time class="entry-date" datetime="2017-03-16T10:32:34-07:00">
				March 16, 2017			</time>
	 	</li>
	 		 	
	 		 	<li>
	 		Written by:	 		
	 		<a class="url fn n" href="http://awate.com/author/dawitmesfin/" title="View all posts by Dawit Mesfin" rel="author">Dawit Mesfin</a>
	 	</li>
	 		 	
	 		 	<li>
	 		<a href="http://awate.com/nakfas-symbolic-value/#comments"><span class="dsq-postid" data-dsqidentifier="165824 http://awate.com/?p=165824"><b>2</b> Replies</span></a>	 	</li>
	 		 </ul> 	
	  				
		</header>
		
		
				<aside class="gk-post-meta">
	<ul>
				<li>
			Category:			<a href="http://awate.com/category/articles/" rel="category tag">Articles</a>		</li>
				 	
		<li>
			<a href="http://awate.com/nakfas-symbolic-value/" title="Permalink to Nakfa’s Symbolic Value" rel="bookmark">permalink</a>
			
				
		</li>
			
				
				
							    <li class="author">
		        <img alt='' src='http://2.gravatar.com/avatar/563226499d49226101a59994e6c4741a?s=40&#038;d=identicon&#038;r=g' srcset='http://2.gravatar.com/avatar/563226499d49226101a59994e6c4741a?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />		        
                <a href="http://awate.com/author/dawitmesfin/" class="gk-author-name" rel="author">
                    Dawit Mesfin 
                </a>
	               
	            		            
	            		    </li>
		    				  		<li class="asideadsense">
		<div id="text-18" class="box   onlyDesktop widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Wide Scrapper - Left Side -->
<ins class="adsbygoogle"
     style="display:inline-block;width:160px;height:600px"
     data-ad-client="ca-pub-7042793297334268"
     data-ad-slot="8169050275"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div>		</li>
			</ul>
</aside>
			
		<section class="content">
		
		<figure class="featured-image">
		<img width="714" height="480" src="http://awate.com/wp-content/uploads/2017/03/dawit-mesfin-2017.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="dawit-mesfin-2017" srcset="http://awate.com/wp-content/uploads/2017/03/dawit-mesfin-2017.jpg 714w, http://awate.com/wp-content/uploads/2017/03/dawit-mesfin-2017-300x202.jpg 300w" sizes="(max-width: 714px) 100vw, 714px" />		
								</figure>
				<!-- google_ad_section_start --><span class="wpsr_floatbts_anchor" data-offset="-1125" ></span><p>It is embarrassing to witness, in this day and age, abnormal developments creep into our campaigns for human and democratic rights of Eritreans. The aim of the sectarian and ethnocentric maneuver is to sow discord between groups, loosen our <em>Ghedli</em>-history that binds us together and then destroy the social fabric of our communities. The <em>Agazian</em> extremists think that religion and ethnicity provide them with the general model that they have of themselves and their world. Well, they are wrong because Nakfa proved them wrong time and time again. Allow me to clarify my point.</p>
<p>The aim of the promoters of these prejudiced values, simply stated, is to change the course of our Ghedli experience in order to appropriate more maneuverability for their crusades. Moreover, take the <em>Ghedli</em> mind-set off the Eritrean identity then he/she will not stand on his dignity. This fanaticism, as far as they are concerned, is what will feed discord and division among us. And that is precisely why we must play an active role in opposing hate sermons and extremism that are being unpacked in our backyards.</p>
<p>The falsification of our history, through efforts exerted by these so called <em>Agazians</em>, pure racialists, is a disgrace, to say the least. The notions they have espoused and are advancing show that they have an obvious interest in a neo-Unionist position.  They do not realize that attacking the credibility of our historic memory will backfire on them.</p>
<p>I am in no doubt that we Eritreans know about and enamored of our history. We know it is a history full of heroism.  However, there is also another side to our victory.  In 1991, as we immersed ourselves in the exhilaration of our victory other forces went to work which would prevent us achieving a true victory – that of democracy and pluralism.  Instead, those forces, under Isaias Afwerki’s leadership, short-changed us, ushering in the politics of the victorious.</p>
<p>The victorious, as it evolved out of the progressive <em>Ghedli</em> into PFDJ, transformed itself into an authoritarian political party that dominated the post-war politics of Eritrea. It was not created around the need to win elections, but rather, as a highly regimented military organisation, its aim was to consolidate power. Sadly, the future that was supposed to ensue after liberation was all based on fake promises.</p>
<p>Now we find ourselves in a different era all together – an era which is eroding that numinous history.  Regrettably, the dark post-independence era that has dawned on Eritrea has so unsettled many of us it is making us forget how our prized success was achieved.  Alas, we are also seeing that some individuals who are angered by the disastrous developments in the country are beginning to challenge and refute facts of our history. Personally, I cannot deny the various components of my national identity which is shaped by our struggle, is important to me. However, I cannot afford to allow my frustrations and indignation at the prevailing injustice get the better of me.</p>
<p>I do not agree with those who totally blame the past for today’s pains. I still believe that Eritrea’s future is rooted in its past. The reason I am exalting our pre-independence history – at least a good part of it &#8211; is due the fact it is the only one I am familiar with.  Many Eritreans of my generation either played a part in, or lived through, the painful 30-year war for independence. Many more supported the revolution and contributed towards its historic conclusion. Moreover, many of us have siblings, friends, relatives and loved ones who took part in the raging conflict in the battlefields of Eritrea. The majority of the fighters are still with us – some are still serving the current regime and others, unhappy with the way the Eritrean dream turned out under PFDJ’s leadership, have turned their back on the Government of Eritrea, but not the struggle for independence.</p>
<p>In these times of adversity I think of what Nakfa means to me. I am reminded of how Nakfa sustained a series of persistent attacks by the Ethiopian Army during late 70s and 80s. In my mind’s eye I can still see our freedom fighters’ trench line that was dug in around the Den-Den Mountain which was crucial in the defense of Nakfa.  I know the successive battles and counter offensives carried out to defend the Nakfa front came at a huge price – the costs simply defy imagination. What I can say is that Nakfa became the most potent symbol of resistance because the Ethiopians, even with the help of air power and massive support from the Soviet Union, could not break its defenses for years.</p>
<p>When I think of Nakfa I think of Omar Sefaf, the veteran fighter who joined the independence struggle in 1966. During the Nadew offensive he was the Battalion Commander within 13<sup>th</sup> Brigade, 61<sup>st</sup> Division. His fellow combatants tell stories of how he fell in <em>Harat Harmaz</em>, mountainous area of Sahel. Again, when I think of Nakfa my mind goes back to the memories of wedi Naf&#8217;E who was full of youthful exuberance. He loved sports, and by far, the best runner in his unit. His friends say he was a brave warrior. In 1985 he fell in defense of the Nakfa front. His fellow-combatants still remember of the words he uttered before he took his last breath. Wedi Naf&#8217;E is survived by Keriya Hassan, his wife, fellow combatant, and their son who still remains attached to Nakfa through his father’s blood and burial ground.</p>
<p>We seem to be confused about many things these days, including our relationship with our own history. And I think that is to be expected as doubts and revisionist attitudes are corrupting the minds of those who lack self-confidence about the eventual success of our current campaigns.</p>
<p>To witness a characterless campaign by those who have taken pseudo-position is an embarrassment, to say the least.  It is strange to see them embark on endeavors to reshape history by belittling and repudiating past realities and by ignoring the essential facts of our nationalist struggle.</p>
<p>How can one forget the voluntary forfeiture of one’s right to life in order to save fellow comrades? How can one forget the overwhelmingly austere conditions that engulfed the young fighters, the ululating female combatants who marched into battlefields so valiantly? The soulful music of resistance that moved our hearts, and most of all, the mothers who stood upright in the face of their children’s bitter martyrdom still resonate with us.</p>
<p>The spell of Nakfa will not, and cannot be broken by such distractions. As the detractors are horsing around with the Tigray-tigrigni aspiration, which is sterile in nature and a gift to PFDJ, attempts to detoxify its proponents is a waste of time. This malformed phase of our struggle, like many false prophesies we have witnessed in the past, will fade away in due course. I am moving on self-confidently because I know Nakfa is on my side. I can hear it say: <strong>no to sectarianism and ethnocentrism! </strong></p>
<div class="wp-socializer-buttons clearfix">
	<span class="wpsr-btn">
<!-- Start WP Socializer Plugin - Facebook Button -->
<div class="fb-like" data-href="http://awate.com/nakfas-symbolic-value/" data-share="true" data-layout="button_count" data-show-faces="0" data-action="like" data-colorscheme="light"></div>
<!-- End WP Socializer Plugin - Facebook Button -->
</span>
	<span class="wpsr-btn">
<!-- Start WP Socializer Plugin - Retweet Button -->
<a href="http://twitter.com/share" class="twitter-share-button" data-count="horizontal"  data-lang="en"  data-url="http://awate.com/nakfas-symbolic-value/" data-text="Nakfa’s Symbolic Value - "></a>
<!-- End WP Socializer Plugin - Retweet Button -->
</span>
	<span class="wpsr-btn">
<!-- Start WP Socializer Plugin - +1 Button -->
<div class="g-plusone" data-size="medium" data-href="http://awate.com/nakfas-symbolic-value/"></div>
<!-- End WP Socializer Plugin - +1 Button -->
</span>
	<span class="wpsr-btn">
<!-- Start WP Socializer Plugin - StumbleUpon Button -->
<su:badge layout="1"></su:badge>
<!-- End WP Socializer Plugin - StumbleUpon Button -->
</span>
        <span class="wpsr-btn">
<!-- Start WP Socializer Plugin - Pinterest Button -->
<div style="padding-right:50px"><a href="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fawate.com%2Fnakfas-symbolic-value%2F&amp;media=http%3A%2F%2Fawate.com%2Fwp-content%2Fuploads%2F2017%2F03%2Fdawit-mesfin-2017.jpg"  data-pin-do="buttonPin" data-pin-config="beside" ><img border="0" src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" alt="Pinterest" title="Pin It" /></a></div>
<!-- End WP Socializer Plugin - Pinterest Button -->
</span>
        <span class="wpsr-btn">
<!-- Start WP Socializer Plugin - Reddit Button -->
<script type="text/javascript">reddit_url = "http://awate.com/nakfas-symbolic-value/";reddit_title = "Nakfa’s Symbolic Value";reddit_newwindow="1";</script><script type="text/javascript" src="http://www.reddit.com/static/button/button1.js"></script>
<!-- End WP Socializer Plugin - Reddit Button -->
</span>
</div><!-- google_ad_section_end --> 			
								</section>
				
		

		
		<footer>
		<section id="gk-social-api"></section>	</footer>
		</article>
					
			
<div id="disqus_thread">
            <div id="dsq-content">


            <ul id="dsq-comments">
                    <li class="comment even thread-even depth-1" id="dsq-comment-213165">
        <div id="dsq-comment-header-213165" class="dsq-comment-header">
            <cite id="dsq-cite-213165">
                <span id="dsq-author-user-213165">Tksi.Amba</span>
            </cite>
        </div>
        <div id="dsq-comment-body-213165" class="dsq-comment-body">
            <div id="dsq-comment-message-213165" class="dsq-comment-message"><p>Hi Everyone,</p>
<p>Can you please recommend books that give a fair and balanced account of the battles from the Eritrean side ? I&#8217;ve read a lot from the Ethiopian side and would like to read about it from the Eritrean side. </p>
<p>Thank you</p>
</div>
        </div>

    </li><!-- #comment-## -->
    <li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-213164">
        <div id="dsq-comment-header-213164" class="dsq-comment-header">
            <cite id="dsq-cite-213164">
                <span id="dsq-author-user-213164">Nitricc</span>
            </cite>
        </div>
        <div id="dsq-comment-body-213164" class="dsq-comment-body">
            <div id="dsq-comment-message-213164" class="dsq-comment-message"><p>Hi Dawit;  tell them as is, little do they know. I have no idea where Eritrea is but I am a the biggest and the proudest of Nakfa! there is to be, that should give you the meaning of Nakfa and its power on Eritreans regardless where they are.</p>
</div>
        </div>

    </li><!-- #comment-## -->
            </ul>


        </div>

    </div>

<script type="text/javascript">
var disqus_url = 'http://awate.com/nakfas-symbolic-value/';
var disqus_identifier = '165824 http://awate.com/?p=165824';
var disqus_container_id = 'disqus_thread';
var disqus_shortname = 'awate';
var disqus_title = "Nakfa’s Symbolic Value";
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    
    this.page.remote_auth_s3 = 'W10= aff8ee2e593247ad29ea41ee74f105d123f82e32 1489687696';
this.page.api_key = 'FPuR5QvYoiNmeLwRTO3s6LsRU3PHgyM9POVoESrBJOBerhHvbqQmNK6sfGO1O253';
this.sso = {
          name: "Awate.com",
          button: "",
          url: "http://awate.com/wp-login.php",
          logout: "http://awate.com/wp-login.php?action=logout",
          width: "800",
          height: "700"
    };
    this.language = '';
        this.callbacks.onReady.push(function () {

        // sync comments in the background so we don't block the page
        var script = document.createElement('script');
        script.async = true;
        script.src = '?cf_action=sync_comments&post_id=165824';

        var firstScript = document.getElementsByTagName('script')[0];
        firstScript.parentNode.insertBefore(script, firstScript);
    });
    
    if (disqus_config_custom) {
        disqus_config_custom.call(this);
    }
};

(function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>

			
						</div>
	
	
</section>

		
								<div id="gk-mainbody-bottom">
					<div id="widget_gk_nsp-19" class="box  nsphover all widget_gk_nsp"><div class="gk-nsp mobile_layout horizontal" data-cols="2" data-rows="2" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 0px 15px 12px 15px;"><a href="http://awate.com/a-group-of-eritreans-to-issue-a-memorandum-of-understanding/" class="gk-responsive gk-image-link"  style="margin: 10px 0 ;"><img src="http://awate.com/wp-content/themes/News/gavern/cache_nsp/gean-initiaative-news-widget_gk_nsp-19.jpg" alt="" class="gk-nsp-image gk-responsive" height="180" width="315" /></a><h3 class="gk-nsp-header"><a href="http://awate.com/a-group-of-eritreans-to-issue-a-memorandum-of-understanding/" title="A Group of Eritreans To Issue a Memorandum of Understanding">A Group of Eritreans To Issue a Memorandum&hellip;</a></h3><p class="gk-nsp-info"><span class="gk-nsp-date">26 Feb 2017</span> <a href="http://awate.com/author/gedab/" class="gk-nsp-author">Gedab News</a> <a href="http://awate.com/a-group-of-eritreans-to-issue-a-memorandum-of-understanding/#comments">Comments (7)</a></p><p class="gk-nsp-text">A group of Eritreans representing a wide array of civil and political affiliations has agreed on key issues regarding the&hellip;</p></div><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 0px 15px 12px 15px;"><a href="http://awate.com/a-new-book-abyssinian-orthodox-tewahdo-church-history-by-semere-habtemariam/" class="gk-responsive gk-image-link"  style="margin: 10px 0 ;"><img src="http://awate.com/wp-content/themes/News/gavern/cache_nsp/abyssinian-orthodox-church-widget_gk_nsp-19.jpg" alt="" class="gk-nsp-image gk-responsive" height="180" width="315" /></a><h3 class="gk-nsp-header"><a href="http://awate.com/a-new-book-abyssinian-orthodox-tewahdo-church-history-by-semere-habtemariam/" title="A New Book: Abyssinian Orthodox Tewahdo Church History By Semere Habtemariam">A New Book: Abyssinian Orthodox Tewahdo Church History&hellip;</a></h3><p class="gk-nsp-info"><span class="gk-nsp-date">23 Feb 2017</span> <a href="http://awate.com/author/awatestaff/" class="gk-nsp-author">awatestaff</a> <a href="http://awate.com/a-new-book-abyssinian-orthodox-tewahdo-church-history-by-semere-habtemariam/#comments">Comments (380)</a></p><p class="gk-nsp-text">A New Book by Semere Tesfamicael Habtemariam
Reflections on the History of the Abyssinian Orthodox Tewahdo Church

Paperback: 312 pages
Publisher: The Red Sea Press,&hellip;</p></div><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 0px 15px 12px 15px;"><a href="http://awate.com/the-village-of-wehni-ber-chapter-2/" class="gk-responsive gk-image-link"  style="margin: 10px 0 ;"><img src="http://awate.com/wp-content/themes/News/gavern/cache_nsp/legend-of-sheba-solomon-minilik1-widget_gk_nsp-19.jpg" alt="" class="gk-nsp-image gk-responsive" height="180" width="315" /></a><h3 class="gk-nsp-header"><a href="http://awate.com/the-village-of-wehni-ber-chapter-2/" title="The Village Of Wehni-Ber (Chapter 2)">The Village Of Wehni-Ber (Chapter 2)</a></h3><p class="gk-nsp-info"><span class="gk-nsp-date">21 Feb 2017</span> <a href="http://awate.com/author/gadi/" class="gk-nsp-author">Saleh "Gadi" Johar</a> <a href="http://awate.com/the-village-of-wehni-ber-chapter-2/#comments">Comments (150)</a></p><p class="gk-nsp-text">The following is chapter 2 of the historical novel, "Of Kings And Bandits"
________________________________________________________________
Mokria, a young Ethiopian boy, glanced at the&hellip;</p></div><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 0px 15px 12px 15px;"><a href="http://awate.com/chalachew-and-the-abyssinian-violin/" class="gk-responsive gk-image-link"  style="margin: 10px 0 ;"><img src="http://awate.com/wp-content/themes/News/gavern/cache_nsp/chalachew-amharic-masinko-widget_gk_nsp-19.jpg" alt="" class="gk-nsp-image gk-responsive" height="180" width="315" /></a><h3 class="gk-nsp-header"><a href="http://awate.com/chalachew-and-the-abyssinian-violin/" title="Chalachew And The Abyssinian Violin">Chalachew And The Abyssinian Violin</a></h3><p class="gk-nsp-info"><span class="gk-nsp-date">19 Feb 2017</span> <a href="http://awate.com/author/awatestaff/" class="gk-nsp-author">awatestaff</a> <a href="http://awate.com/chalachew-and-the-abyssinian-violin/#comments">Comments (444)</a></p><p class="gk-nsp-text">Today we bring you an unadulterated Abyssinian Masinqo in Amharic, or Chrawata in Tigrinya. It’s a pure countryside art that&hellip;</p></div></div></div></div></div></div>				</div>
							</div><!-- end of the #gk-content-wrap -->
			
					</section><!-- end of the mainbody section -->
	
						<aside id="gk-sidebar">
			<div id="text-4" class="box  widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Side Bar Rectangle -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-7042793297334268"
     data-ad-slot="8745974276"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div><div id="widget_gk_tabs-4" class="box  bigtitle all widget_gk_tabs"><h3 class="box-title">Awate Forum</h3><div class="gk-tabs" data-event="click" data-autoanim="disabled" data-speed="50" data-interval="7000"><div class="gk-tabs-wrap"><ol class="gk-tabs-nav"><li class="active">Recent        </li><li>Popular</li><li>Top Awatistas</li></ol><div class="gk-tabs-container"><div class="gk-tabs-item active"><div id="tp_disqusrecentcomments-3" class="box tp_disqusrecentcomments "><div><div id='recentcomments' class='dsq-widget'><script type='text/javascript' src='http://awate.disqus.com/recent_comments_widget.js?num_items=10&hide_avatars=1&avatar_size=32&excerpt_length=200&hide_mods=0'></script></div></div></div></div><div class="gk-tabs-item"><div id="tp_disquspopularthreads-2" class="box tp_disquspopularthreads"><div><div id='popularthreads' class='dsq-widget'><script type='text/javascript' src='http://awate.disqus.com/popular_threads_widget.js?num_items=8'></script></div></div></div></div><div class="gk-tabs-item"><div id="tp_disqustopcommenters-2" class="box tp_disqustopcommenters"><div><div id='topcommenters' class='dsq-widget'><script type='text/javascript' src='http://awate.disqus.com/top_commenters_widget.js?num_items=8&hide_mods=1&hide_avatars=0&avatar_size=32'></script></div></div></div></div></div></div></div></div><div id="widget_gk_nsp-15" class="box  widget_gk_nsp"><h3 class="box-title">More Articles</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="2" data-links="" data-autoanim="on" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-2"><div class="gk-nsp-arts-page gk-nsp-cols-2"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="http://awate.com/adulisian-narratives-standing-athwart-the-abyssinian-paradigm/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="http://awate.com/wp-content/themes/News/gavern/cache_nsp/Adulisian-paradigm-widget_gk_nsp-15.jpg" alt="" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="http://awate.com/adulisian-narratives-standing-athwart-the-abyssinian-paradigm/" title="Adulisian Narratives: Standing Athwart The Abyssinian Paradigm">Adulisian Narratives: Standing Athwart The Abyssinian Paradigm</a></h3><p class="gk-nsp-info"><a href="http://awate.com/author/gheteb/" class="gk-nsp-author">"Gheteb"</a>,  <a href="http://awate.com/adulisian-narratives-standing-athwart-the-abyssinian-paradigm/#comments">Comments (259)</a></p><p class="gk-nsp-text">



The ancient port town of Adulis or Aduli buried in a helluva of sand is not standing. You may not see its&hellip;</p></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="http://awate.com/gean-memorandum-of-understanding/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="http://awate.com/wp-content/themes/News/gavern/cache_nsp/gean-memorandum-of-understanding-widget_gk_nsp-15.jpg" alt="" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="http://awate.com/gean-memorandum-of-understanding/" title="GEAN: Memorandum of Understanding">GEAN: Memorandum of Understanding</a></h3><p class="gk-nsp-info"><a href="http://awate.com/author/awatestaff/" class="gk-nsp-author">awatestaff</a>,  <a href="http://awate.com/gean-memorandum-of-understanding/#comments">Comments (180)</a></p><p class="gk-nsp-text">On the initiative of Global Eritrean Advocacy Network (GEAN), and after a series of deliberations, we, the undersigned individuals, civil&hellip;</p></div></div><div class="gk-nsp-arts-page gk-nsp-cols-2"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="http://awate.com/the-new-wave-of-muslim-preachers/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="http://awate.com/wp-content/themes/News/gavern/cache_nsp/a-new-wave-of-Muslim-preachers-widget_gk_nsp-15.jpg" alt="" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="http://awate.com/the-new-wave-of-muslim-preachers/" title="The New Wave of Muslim Preachers">The New Wave of Muslim Preachers</a></h3><p class="gk-nsp-info"><a href="http://awate.com/author/gadi/" class="gk-nsp-author">Saleh "Gadi" Johar</a>,  <a href="http://awate.com/the-new-wave-of-muslim-preachers/#comments">Comments (306)</a></p><p class="gk-nsp-text">The last decade or so has been difficult for Muslims in many countries, but Muslims are still suffering the most in&hellip;</p></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="http://awate.com/ethiopia-kills-13-rebels-near-assosa-and-the-renaissance-dam/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="http://awate.com/wp-content/themes/News/gavern/cache_nsp/benshangul-rebel-attack-in-Ethiopia-widget_gk_nsp-15.jpg" alt="" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="http://awate.com/ethiopia-kills-13-rebels-near-assosa-and-the-renaissance-dam/" title="Ethiopia Kills 13 Rebels Near Assosa and The Renaissance Dam">Ethiopia Kills 13 Rebels Near Assosa and The Renaissance Dam</a></h3><p class="gk-nsp-info"><a href="http://awate.com/author/gedab/" class="gk-nsp-author">Gedab News</a>,  <a href="http://awate.com/ethiopia-kills-13-rebels-near-assosa-and-the-renaissance-dam/#comments">Comments (404)</a></p><p class="gk-nsp-text">Tsadeq Hagos, the Ethiopian State Minister for communication stated that security forces clashed with a the Benshangul rebel organization killing&hellip;</p></div></div></div><div class="gk-nsp-arts-nav"><ul class="gk-nsp-pagination"><li>1</li><li>2</li></ul></div></div></div></div><div id="text-5" class="box  widget_text">			<div class="textwidget"><div style="margin-top: 10px; margin-bottom: 10px">
<img SRC="http://awate.com/wp-content/uploads/2014/04/quotes.jpg"  WIDTH=290 HEIGHT=152/>
</div></div>
		</div><div id="calendar-3" class="box  widget_calendar"><h3 class="box-title">Calendar</h3><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>March 2017</caption>
	<thead>
	<tr>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
		<th scope="col" title="Sunday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="http://awate.com/2017/02/">&laquo; Feb</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="2" class="pad">&nbsp;</td><td><a href="http://awate.com/2017/03/01/" aria-label="Posts published on March 1, 2017">1</a></td><td>2</td><td>3</td><td>4</td><td>5</td>
	</tr>
	<tr>
		<td>6</td><td>7</td><td><a href="http://awate.com/2017/03/08/" aria-label="Posts published on March 8, 2017">8</a></td><td>9</td><td><a href="http://awate.com/2017/03/10/" aria-label="Posts published on March 10, 2017">10</a></td><td>11</td><td>12</td>
	</tr>
	<tr>
		<td><a href="http://awate.com/2017/03/13/" aria-label="Posts published on March 13, 2017">13</a></td><td>14</td><td>15</td><td id="today"><a href="http://awate.com/2017/03/16/" aria-label="Posts published on March 16, 2017">16</a></td><td>17</td><td>18</td><td>19</td>
	</tr>
	<tr>
		<td>20</td><td>21</td><td>22</td><td>23</td><td>24</td><td>25</td><td>26</td>
	</tr>
	<tr>
		<td>27</td><td>28</td><td>29</td><td>30</td><td>31</td>
		<td class="pad" colspan="2">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></div><div id="albatross_facebook-widget-2" class="box  albatross_facebook"><div style="background-color:;"><iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2Fpages/awatecom/211930818821450&amp;width&amp;height&amp;colorscheme=light&amp;show_faces=true&amp;header=true&amp;stream=false&amp;show_border=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; height:275px;" allowTransparency="true"></iframe></div></div>		</aside>
						<!--[if IE 8]>
		<div class="ie8clear"></div>
		<![endif]-->
	</div><!-- end of the #gk-mainbody-columns -->
</div><!-- end of the .gk-page-wrap section -->	


<div id="gk-bottom2" class="gk-page widget-area">
	<div id="text-11" class="box  widget_text col6 nth1 last4"><h3 class="box-title">Music</h3>			<div class="textwidget"><ul>
<li> <a href="http://www.teshamo.com/index.php?option=com_wrapper&Itemid=37">Eritrean Music</a></li>			

<li> <a href="http://www.addiszefen.com/">Addis Zefen</a></li>
			<li> <a href="http://www.sudaneseonline.org/musicIndex.html">Sudanese Music</a></li>
			<li> <a href="http://somalimuzic.com/">Somali Music</a></li>
			<li> <a href="http://www-sul.stanford.edu/depts/ssrg/africa/music.html">African Music</a></li>
			<li> <a href="http://www.allmusic.com/style/traditional-middle-eastern-folk-ma0000012029">Middle Eastern Music</a></li>
			
</ul></div>
		</div><div id="text-12" class="box  widget_text col6 nth2 last4"><h3 class="box-title">Cartoons</h3>			<div class="textwidget"><ul>
			<li> <a href="http://aminarts.com/">Amin Arts</a></li>
			
			
</ul></div>
		</div><div id="text-15" class="box  widget_text col6 nth3 last4"><h3 class="box-title">Links</h3>			<div class="textwidget"><ul>
<li><a href="http://awate.com/?p=583">Eritrean Links </a></li>
			<li> <a href="http://awate.com/?p=583">BBC</a></li>
			<li> <a href="http://awate.com/?p=583">Guardian</a></li>
			<li> <a href="http://awate.com/?p=583">New York Times</a></li>
			<li> <a href="http://awate.com/?p=583">Washingtom Post</a></li>
			<li> <a href="http://awate.com/?p=583">Al-Ahram</a></li>
</ul>
</div>
		</div><div id="text-14" class="box  widget_text col6 nth4 last4"><h3 class="box-title">Follow Us</h3>			<div class="textwidget"><ul>
			<li> <a href="https://www.facebook.com/pages/awatecom/211930818821450?ref=hl">Facebook</a></li>
			<li> <a href="https://twitter.com/awate2">Twitter</a></li>
			<li> <a href="#">YouTube</a></li>
</ul></div>
		</div>	<!--[if IE 8]>
	<div class="ie8clear"></div>
	<![endif]-->
</div>

	<footer id="gk-footer" class="gk-page">			
	
		<ul id="footer-menu" class="menu gk_normal"><li id="menu-item-14222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-14222"><a href="http://awate.com/">Home</a></li>
<li id="menu-item-14223" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14223"><a href="http://awate.com/about-us/">About Us</a></li>
<li id="menu-item-14224" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14224"><a href="http://awate.com/archives/">Archives</a></li>
<li id="menu-item-14226" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14226"><a href="http://awate.com/links/">Links Welcome Page</a></li>
<li id="menu-item-14227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14227"><a href="http://awate.com/jebena-awate-open-thread/">Merhaba: Awate Open Thread</a></li>
<li id="menu-item-14228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14228"><a href="http://awate.com/posting-guidelines/">Posting Guidelines</a></li>
<li id="menu-item-14231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14231"><a href="http://awate.com/category/%d8%b9%d8%b1%d8%a8%d9%8a/">عربي</a></li>
<li id="menu-item-14232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14232"><a href="http://awate.com/category/%e1%89%b5%e1%8c%8d%e1%88%ad%e1%8a%9b/">ትግርኛ</a></li>
</ul>		
		<div class="gk-copyrights">
			Copyright &copy; 2000-2017 Awate. All Rights Reserved.
		</div>
		
		
				
			</footer>
	
	
<div id="gk-popup-login">	
	<div class="gk-popup-wrap">
				    
			
		<form name="loginform" id="loginform" action="http://awate.com/wp-login.php" method="post">
			
			<p class="login-username">
				<label for="user_login">Username</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" />
			</p>
			<p class="login-password">
				<label for="user_pass">Password</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
			</p>
			
			<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" /> Remember Me</label></p>
			<p class="login-submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button-primary" value="Log In" />
				<input type="hidden" name="redirect_to" value="http://awate.com/nakfas-symbolic-value/" />
			</p>
			
		</form>		
			</div>
</div>

<div id="gk-popup-overlay"></div>
	
	
		
		
		
	
	
		
		
		<script type="text/javascript">
    var pluginUrl = 'http://awate.com/wp-content/plugins/contus-video-gallery/';
	</script>
	        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'awate';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1) {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        <div class="wpsr-floatbar-float_left wpsr-floatbar-white wpsr-floatbar-movable  clearfix"  data-mobmode="0" ><div class="wpsr_floatbt"></div><div class="wpsr_floatbt">
<!-- Start WP Socializer Plugin - +1 Button -->
<div class="g-plusone" data-size="tall" data-href="http://awate.com/nakfas-symbolic-value/"></div>
<!-- End WP Socializer Plugin - +1 Button -->
</div><div class="wpsr_floatbt">
<!-- Start WP Socializer Plugin - Retweet Button -->
<a href="http://twitter.com/share" class="twitter-share-button" data-count="vertical"  data-lang="en"  data-url="http://awate.com/nakfas-symbolic-value/" data-text="Nakfa’s Symbolic Value - "></a>
<!-- End WP Socializer Plugin - Retweet Button -->
</div><div class="wpsr_floatbt">
<!-- Start WP Socializer Plugin - StumbleUpon Button -->
<su:badge layout="5"></su:badge>
<!-- End WP Socializer Plugin - StumbleUpon Button -->
</div><div class="wpsr_floatbt"><a href="mailto:?to=&subject=Nakfa%E2%80%99s+Symbolic+Value&body=It+is+embarrassing+to+witness%2C+in+this+day+and+age%2C+abnormal+developments+creep+into+our+campaigns+for+human+and+democratic+rights+of+Eritreans.+The+aim+of+the+sectarian+and+ethnocentric+maneuver+is+to+sow+discord+between+groups%2C+loosen+our+Ghedli-hi%20-%20http://awate.com/nakfas-symbolic-value/" title="Email this" target="_blank" rel="nofollow"class="wp-socializer-single"><img src="http://awate.com/wp-content/plugins/wp-socializer/public/social-icons/32/email.png" alt="Email" border="0"/></a></div><div class="wpsr_floatbt"><a href="http://www.printfriendly.com/print?url=http%3A%2F%2Fawate.com%2Fnakfas-symbolic-value%2F" title="Print this article" target="_blank" rel="nofollow"class="wp-socializer-single"><img src="http://awate.com/wp-content/plugins/wp-socializer/public/social-icons/32/printfriendly.png" alt="Print" border="0"/></a></div><div class="wpsr_floatbt"></div></div><div class="wpsr_shareminbt"></div>
<!--WP Socializer v2.4.9.9 - Scripts Loader-->
<script type="text/javascript">
var wu=["https://platform.twitter.com/widgets.js","https://connect.facebook.net/en_US/all.js#xfbml=1","https://apis.google.com/js/plusone.js","https://platform.stumbleupon.com/1/widgets.js","https://assets.pinterest.com/js/pinit.js"],wc=5;
function wpsrload(){ for(var i=0;i<wc;i++){wpsrasync(wu[i]);} }
function wpsrasync(u){var a=document.createElement("script");a.type="text/javascript";a.async=true;a.src=u;var s=document.getElementsByTagName("script")[0];s.parentNode.insertBefore(a,s);} wpsrload();
</script>
<!--End WP Socializer - Scripts Loader-->
<script type='text/javascript' src='http://awate.com/wp-includes/js/comment-reply.min.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://awate.com/wp-content/themes/News/js/gk.scripts.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://awate.com/wp-content/themes/News/js/shortcodes.typography.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://awate.com/wp-content/themes/News/js/shortcodes.elements.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://awate.com/wp-content/themes/News/js/shortcodes.template.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://awate.com/wp-includes/js/thickbox/thickbox.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://awate.com/wp-content/plugins/wp-socializer/public/js/wp-socializer-bookmark-js.js?ver=2.4.9.9'></script>
<script type='text/javascript' src='http://awate.com/wp-content/themes/News/js/widgets/nsp.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://awate.com/wp-content/themes/News/js/widgets/tabs.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://awate.com/wp-includes/js/wp-embed.min.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://awate.com/wp-content/themes/News/js/gk.menu.js?ver=4.6.4'></script>
<script type='text/javascript' src='http://awate.com/wp-content/plugins/contus-video-gallery/js/playlist.min.js?ver=4.6.4'></script>
		<div id="wprmenu_bar" class="wprmenu_bar">
			<div class="wprmenu_icon">
				<span class="wprmenu_ic_1"></span>
				<span class="wprmenu_ic_2"></span>
				<span class="wprmenu_ic_3"></span>
			</div>
			<div class="menu_title">
											</div>
		</div>

		<div id="wprmenu_menu" class="wprmenu_levels left wprmenu_custom_icons">
						<ul id="wprmenu_menu_ul">
				<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-4064"><a href="http://awate.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-55114"><a href="http://awate.com/category/awate-team/">Awate Team</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55106"><a href="http://awate.com/category/pencil/">Pencil</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55096"><a href="http://awate.com/category/gedab-news/">Gedab News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-55167"><a href="http://awate.com/category/articles/">Articles</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-55098"><a href="http://awate.com/category/columns/">Columns</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55107"><a href="http://awate.com/category/perspective/">Perspective</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55111"><a href="http://awate.com/category/tebeges/">Tebeges</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65966"><a href="http://awate.com/category/alnahda/">Al-Nahda</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55105"><a href="http://awate.com/category/negarit/">Negarit</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55108"><a href="http://awate.com/category/pointblank/">Pointblank</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55097"><a href="http://awate.com/category/almaseer/">AlMaseer</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55112"><a href="http://awate.com/category/u-turn/">U-Turn</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55101"><a href="http://awate.com/category/flipside/">Flipside</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55099"><a href="http://awate.com/category/belly-of-the-beast/">Belly Of The Beast</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55100"><a href="http://awate.com/category/branna/">Branna</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55102"><a href="http://awate.com/category/harmony/">Harmony</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55103"><a href="http://awate.com/category/insight/">Insight</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55104"><a href="http://awate.com/category/kind-citizen/">Kind Citizen</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55109"><a href="http://awate.com/category/reflections/">Reflections</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55110"><a href="http://awate.com/category/spotlight/">Spotlight</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55113"><a href="http://awate.com/category/verbatim/">Verbatim</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55094"><a href="http://awate.com/category/%d8%b9%d8%b1%d8%a8%d9%8a/">عربي</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55095"><a href="http://awate.com/category/%e1%89%b5%e1%8c%8d%e1%88%ad%e1%8a%9b/">ትግርኛ</a></li>
			</ul>
					</div>
			
			<script type="text/javascript">
		  var _gaq = _gaq || [];
		  _gaq.push(['_setAccount', 'UA-18935809-1']);
		  _gaq.push(['_trackPageview']);
		
		  (function() {
		    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
		  })();
		</script>
		</body>
</html>